App unable to load


Hi @sergy, its not working both ways.
Tried downloading latest version from windows store as well as from official site. Nothing helped.


Could you please clarify one thing. Do experience a problem with downloading the app or with its installation? If there is a problem with downloading we can upload it to some cloud file storage comfortable to you.


Everything works fine, but when I try to open the app, nothing happens! :frowning:


Having the same problem here.

OS version: Windows 10 Enterprise (Version 1703 OS Build 15063.1746)

Tried both the installer and portable version. Windows event log gives me these two events:

<Event xmlns="">
        <Provider Name="Application Error" /> 
        <EventID Qualifiers="0">1000</EventID> 
        <TimeCreated SystemTime="2019-05-10T13:37:28.920763700Z" /> 
        <Security /> 
        <Data /> 
        <Data /> 
<Event xmlns="">
        <Provider Name=".NET Runtime" /> 
        <EventID Qualifiers="0">1026</EventID> 
        <TimeCreated SystemTime="2019-05-10T13:37:28.790796900Z" /> 
        <Security /> 
        <Data>Application: Lunacy.exe Framework Version: v4.0.30319 Description: The process was terminated due to an unhandled exception. Exception Info: System.TypeLoadException at Lunacy.App..cctor() Exception Info: System.TypeInitializationException at Lunacy.App.Main()</Data> 


Hello, could you please let us know the following info:

  1. A version of Visual C++
  2. Version of.Net Framework
  3. Is there any Antivirus App installed?
  4. What are the user rights used (admin’s account or not)
  5. What are corporate security policies? (in case of an organization)


Hello, could you please let us know the following info:

  1. A version of Visual C++
  2. Version of.Net Framework
  3. Is there any Antivirus App installed?
  4. What are the user rights used (admin’s account or not)
  5. What are corporate security policies? (in case of an organization)


I am also having issues. Just downloaded the latest version. Using Windows 10 Professional. The app doesn’t start at all when clicked. I tried running as Administrator, disabling both Windows Defender and Malewarebytes and even restarted my computer and it still won’t load the app. I also have the latest Visual C++ and .Net Framework installed.


You may like to try out just released alpha version Lunacy - Ready To Use <<< Significant performance increase!


Has this been resolved?
I’m seeing the same issue, with the same application log messages, for both the version from the windows store and for 4.0.3; I have the most up to date .NET and C++ redist, the links you provided before will not install, as I already have more updated versions. Antivirus is Windows Defender and it is not stopping the program from running.

From Windows application log:
Faulting application name: Lunacy.exe, version:, time stamp: 0x5d03e112
Faulting module name: KERNELBASE.dll, version: 10.0.15063.1836, time stamp: 0xbb572fa7
Exception code: 0xe0434352
Fault offset: 0x000f18e2
Faulting process id: 0x40f0
Faulting application start time: 0x01d526b92173a45b
Faulting application path: C:\Program Files\WindowsApps\Icons8LLC.Lunacy_4.0.0.0_x86__7g68zyg4rddyp\Lunacy.Wpf\Lunacy.exe
Faulting module path: C:\WINDOWS\System32\KERNELBASE.dll
Report Id: c445bfc6-3059-4d37-9205-fd26be5aba54
Faulting package full name: Icons8LLC.Lunacy_4.0.0.0_x86__7g68zyg4rddyp
Faulting package-relative application ID: App

Application: Lunacy.exe
Framework Version: v4.0.30319
Description: The process was terminated due to an unhandled exception.
Exception Info: System.TypeLoadException
at Lunacy.App…cctor()

Exception Info: System.TypeInitializationException
at Lunacy.App.Main()


Could you please send us files from this folder:
(system disk):\Users\ (current user)\AppData\Local\Icons8\Lunacy\Logs


There is no such folder.
There are Lunacy dups in the CrashDumps folder. Would any of those help?


We would recommend you to update your OS till the latest actual version. According to Microsoft, it should help with the 0xe0434352 error. This regular error arises after unsuccessful OS update.


Same problem over here. I downloaded the latest version from the site. Installs just fine. However, nothing happens when I open the app.
Downloaded the latest alpha version. Nothing happened the first time I ran it. After that it does show the loading visual but it still doesn’t do anything.
Finally, I tried disabling my antivirus, but that did not help.
Any ideas?


Hello, Milan! Let’s try to figure it out!
First of all, I need to ask you about your OS. Which build of Windows are you using? Would be cool if you could take a screenshot of your Windows About page
Start>Settings>System>About>Windows specifications

Are you using the latest GPU drivers?

Is everything okay with system rights? Have you tried to open the installer as an administrator?


Hi Artem!
Yes, I’ve tried running both the installer and the app as an admin. It did’n change anything. My GPU is up to date,
Here’s the About page. I might have worse problems than just opening Lunacy :grin: as having no processor is a bit weird, gotta admit.


Hmmm…Are you using the latest version of .net framework & visual c++?
If this will not help I will advise updating your OS to the latest version.

Could you tell me which CPU and GPU are you using?


Yes, .net and c++ are up-to-date as well as the OS.
It’s an i3 5005U and a Radeon R7 M360.


Your OS is not up-to-date. 1803 build is Apr. 2018. Actual version is 1903. We can reproduce your environment only if you update your OS.


Hello. Not sure I am seeing the same error but here is Lumacy’s log file content:

23:19:00.363 Unknown	Default	> Launched on x64 OS
23:19:00.385 Unknown	Error	> AggregateException A Task's exception(s) were not observed either by Waiting on the Task or accessing its Exception property. As a result, the unobserved exception was rethrown by the finalizer thread. / 
 ----> COMException The service cannot be started, either because it is disabled or because it has no enabled devices associated with it.
 /    at System.Runtime.InteropServices.Marshal.ThrowExceptionForHRInternal(Int32 errorCode, IntPtr errorInfo)
   at System.Management.ManagementScope.InitializeGuts(Object o)
   at System.Management.ManagementScope.Initialize()
   at System.Management.ManagementObject.Initialize(Boolean getObject)
   at System.Management.ManagementClass.GetInstances(EnumerationOptions options)
   at Gdf.Common.Desktop.System.SystemInformer.GetVersionInfo() in F:\Source\lunacy\Lunacy\Gdf.Common.Desktop\System\SystemInformer.cs:line 38
   at System.Lazy`1.CreateValue()
   at System.Lazy`1.LazyInitValue()
   at Gdf.Common.Desktop.System.SystemInformer.IsWin10() in F:\Source\lunacy\Lunacy\Gdf.Common.Desktop\System\SystemInformer.cs:line 61
   at Lunacy.App.ReportOsVersion() in F:\Source\lunacy\Lunacy\Lunacy.Wpf\App.xaml.cs:line 283
   at System.Threading.Tasks.Task.Execute()
23:19:00.388 Unknown	Error	> NullReferenceException Object reference not set to an instance of an object. /    at Lunacy.Services.NetDialogService.ExceptionDialog(String title, String message, Exception ex) in F:\Source\lunacy\Lunacy\Lunacy.Wpf\Services\NetDialogService.cs:line 0
   at System.EventHandler`1.Invoke(Object sender, TEventArgs e)
   at System.Threading.Tasks.TaskScheduler.PublishUnobservedTaskException(Object sender, UnobservedTaskExceptionEventArgs ueea)
   at System.Threading.Tasks.TaskExceptionHolder.Finalize()

Since neither the store not the direct download app were running, I downloaded alpha and have been trying to launch the x64 version (x32 also fails)

I should add that I am running Windows 10 Pro Version 1903, build 18362.418.


Installed the latest updated vc_redist.x64.exe and now is working.

Having the same issue, first tried from the windows store, tried to launch it multiple times, tried to launch as admin, nothing.

Next downloaded the windows installer, same thing, it doesn’t launch at all.

Windows 10 64bit 1903 18362.418
32GB Ram
RTX 2070 441.08 driver

error log from event viewer
Faulting application name: Lunacy.exe, version:, time stamp: 0x5dbf14e7
Faulting module name: KERNELBASE.dll, version: 10.0.18362.418, time stamp: 0xfba22159
Exception code: 0xe0434352
Fault offset: 0x000000000003a839
Faulting process id: 0x51d4
Faulting application start time: 0x01d592b68e0033e8
Faulting application path: C:\Program Files\Lunacy\Lunacy.exe
Faulting module path: C:\WINDOWS\System32\KERNELBASE.dll
Report Id: 3f140e24-ae43-4b42-9500-13f3ac3aee7d
Faulting package full name:
Faulting package-relative application ID:

And this is from the lunacy error log in C:\Users\user\AppData\Local\Icons8\Lunacy\Logs
02:21:23.270 Unknown Default > Launched on Windows 10
02:21:23.271 Unknown Default > Launched on x64 OS
02:21:23.320 Unknown Default > Windows - 10 19H1 (1903)
02:21:23.605 Unknown Error > RemotingException Failed to read from an IPC Port: The pipe has been ended.
Server stack trace:
at System.Runtime.Remoting.Channels.Ipc.IpcPort.Read(Byte[] data, Int32 offset, Int32 length)
at System.Runtime.Remoting.Channels.SocketHandler.ReadFromSocket(Byte[] buffer, Int32 offset, Int32 count)
at System.Runtime.Remoting.Channels.SocketHandler.Read(Byte[] buffer, Int32 offset, Int32 count)
at System.Runtime.Remoting.Channels.SocketHandler.ReadAndMatchFourBytes(Byte[] buffer)
at System.Runtime.Remoting.Channels.Tcp.TcpSocketHandler.ReadAndMatchPreamble()
at System.Runtime.Remoting.Channels.Tcp.TcpSocketHandler.ReadVersionAndOperation(UInt16& operation)
at System.Runtime.Remoting.Channels.Ipc.IpcClientHandler.ReadHeaders()
at System.Runtime.Remoting.Channels.Ipc.IpcClientTransportSink.ProcessMessage(IMessage msg, ITransportHeaders requestHeaders, Stream requestStream, ITransportHeaders& responseHeaders, Stream& responseStream)
at System.Runtime.Remoting.Channels.BinaryClientFormatterSink.SyncProcessMessage(IMessage msg)

Exception rethrown at [0]:
at System.Runtime.Remoting.Proxies.RealProxy.HandleReturnMessage(IMessage reqMsg, IMessage retMsg)
at System.Runtime.Remoting.Proxies.RealProxy.PrivateInvoke(MessageData& msgData, Int32 type)
at Microsoft.Shell.SingleInstance1.IPCRemoteService.InvokeFirstInstance(IList1 args)
at Microsoft.Shell.SingleInstance1.SignalFirstInstance(String channelName, IList1 args)
at Microsoft.Shell.SingleInstance`1.InitializeAsFirstInstance(String uniqueName)
at Lunacy.App.Main()