Linux vesion of Lunacy is buggy


The Linux version of Lunacy is very buggy.
It takes a while to open, and when it does, it freezes or there is a problem with the cursor


I’ve asked about your OS and Lunacy versions in another thread, you may post them either here or in that thread. :slight_smile:
As for the cursor issue, is it this one? Mouse icon appears with a Fuzzy Box - Ubuntu 20 - #6 by samuelosoba

The problem still exists.
It takes several minutes to start Lunacy on Linux at high CPU load.

For now actually for v.9.0.9 and v.9.1.1 the startup doesn’t complete for a long time, well over 5 min. Total app freeze at very first launch, no UI, blank frame.
Nothing helps, so for me it is completely unusable on Linux.

I’m running hybrid graphics on my laptop: Intel + nVidia.

What is your OS version?

Pop!_OS 22.04

We’ve checked, and we have 63 users on Pop_OS. So far we haven’t received such reports from other people on this OS. For now you can try updating your drivers, especially for graphics. See if that changes anything.

Pop_OS actually is Ubuntu

You’re right, Pop_OS is based on Ubuntu. Having said that, other Pop_OS users have never reached out to us with that issue, so it’s a good idea to update your drivers first.

I tried different version of nVidia drivers, v.470 and v.525, but this issue has existed since the first versions of Lunacy I tried, that is to say at least since v.8

I have same problem, app freeze at first launch, os is Archlinux, and running hybrid graphics: Intel + Nvidia

I think you should refactor the code related to fonts:

I just tested v.9.2 and everything seems to be fine now, no hang-ups, app launches without freezing.
Looks like it fixed now!
Good job, thanks :+1: