Symbols are missing when I copy them from another file


#1

I have tried to copy over existing symbols from different sketch files. They appear in the target file when I copy and paste while the Lunacy app is open but when I close the app and reopen the file where the copy and paste took place, a red rectangle appears saying that the symbols are missing

Could you please help? I absolutely need to get this to work for productive work ASAP


#2

how to upload logo for my site iklankita


#3

Please, give us more details on this issue: what symbols do you paste? How exactly do you do that?
Do you do all the mentioned actions on the same device, or do you use two/more of them?
Thank you!


#4

Do you mean you’ve created a logo for your website in Lunacy and now need to upload it? Here is an article on how to export things from Lunacy, if that helps: https://docs.icons8.com/export/

If you have any other questions, please ask them here: https://community.icons8.com/c/lunacy we will be glad to be of help!


#5

Hello,

I use some sketch files that were created in the Sketch app by Mac users. If I copy some parts of that file that have symbols and paste them into a new sketch file in Lunacy, everything works fine until I try to reopen the file after closing the session.

I get this: ‘Symbol is missing’

So I basically can’t reuse a lot of existing stuff that was done elsewhere. I do not have the issue if I create my own symbols in Lunacy though.

2020-04-13_9-22-04


#6

Thank you! Is it possible to create a video of the copying process? We’d like to check one theory, but failed to reproduce the issue on our end so far.
Please, make sure to capture the Objects tree on the video, for both the original file and the saved file with the symbols pasted in.


#7

Unfortunately it is difficult for me to capture it in a video because of the sensitive data that the files contain. What I simply tried to do was copy parts of a design in another file that had instances of symbols. Everything appears to look fine at first but when reopening the newly saved file, the symbols stop appearing. For a second I thought it was because the symbol was not being created in the target file but when I checked, that part seemed fine.


#8

I tried to upload a video but I got this message: ‘Sorry, new users can not upload attachments.’


#9

You can send it to lunacy@icons8.com, just write us a little description so we knew who the email is from and could answer asap. Thank you!


#10

I sent it by e-mail as you suggested


#11

Replied with new video


#12

Thank you, we are analyzing it right now, you will get a reply from the team asap.


#13

any updates on this issue?


#14

Not yet, as we are still trying to reproduce the issue on our end.
It would help us a lot, if you could send us the file in question to lunacy@icons8.com, so we could learn what leads to this situation and fix the bug.

We never share the files we get from our users outside of the team, so please don’t worry about the information leaking or anything similar.


#15

I would love to be able to do that but it is hard to pinpoint exactly how this occurs and I end up spending a lot of time just trying to reproduce the issue. I will keep trying and keep you posted.


#16

Ah, I see. In this case, can you just send us the file with those problematic symbols pasted in, so we could try and get this outcome ourselves? Thank you!


#17

I sent the files by email


#18

I have lost my working file me too. Totally fail!

Symbol is missing.


#19

The issue with symbols sent by lunatic55 was solved, turned out the master symbols of overrides were broken in the initial project.


#20

Hi, is it the same issue the OP had? Or is it anything else we can help you with?