App not respect system scaling settings

UI have very small size, I can’t use app because of this.
OS: Fedora 34 (Workstation Edition) x86_64
DE: GNOME
WM: Mutter

This is how the framework works, so in order to fix this we need to wait when it will be fixed on their side.

Running the below on fedora fixed scaling for me as a workaround.

AVALONIA_SCREEN_SCALE_FACTORS=‘DP-0=1.5’ snap run lunacy

For more information see the following.

Thanks for the tip! I’ll pass it on to our team, maybe this info will help us fix this issue faster.

There’s a thread on the Avanlonia framework’s Github page with more details on how to launch the app with a custom UI scaling setting on Linux:

For me, I am using the Flatpak version of Lunacy from Flathub. I’m on Fedora 35 with Wayland, and my display scaling is set to 200%. Running this command in the terminal launches Lunacy with its interface scaled up by a factor of 2, making the app usable:

AVALONIA_GLOBAL_SCALE_FACTOR=2 flatpak run com.icons8.Lunacy

The developers say that they won’t try to auto-detect the user’s display scaling until they port their framework over to Wayland. So this might be the best solution for anyone who needs to use Lunacy right away (Source)

Hope this helps someone.

3 Likes

Thanks, this works very nicely!

Just another question: how do you add this to the .desktop file? By itself, this only works through the command line. Trying to add the variable to the beginning of the command in the .desktop file corrupts it; GNOME Alacarte doesn’t accept it as valid, and forcing it with a text editor makes it disappear from the menu.

Using’s Flatpak’s --env parameters or Flatseal doesn’t change the setting.

Help would be appreciated :slight_smile:

snap version use like this.

AVALONIA_GLOBAL_SCALE_FACTOR=2 snap run lunacy

it works well.

1 Like