Import from Figma doesn't seem to work

Lunacy version: 9.1.1 and 9.2.0.3004
OS version: Ventura 13.2.1

When trying to import a Figma file, the URL input field shows a red border (validation error) - it seems that the file hash (the part of the URL after “/file/”) is longer than expected, as when I remove 2 characters from it, it removes the error, but import naturally doesn’t work since the URL is wrong.

I also just discovered this issue. The actual Figma file URL is two characters longer than what is allowed by the URL field in Lunacy.

We’ve fixed this issue in the up-to-date versions of Lunacy, the current being 9.6.0.5148. You can update directly from Lunacy by pressing Lunacy->About Lunacy->Download or download and install the update via this link: Lunacy Download

BTW, make sure that you have a personal access token before importing a project from Figma with a URL. Here’s an article on how to get it: Manage personal access tokens

Thanks for your reply. The download link you gave is for Mac. Could you provide a link to the Windows version? I suspect the menu option is for Mac too, as I don’t see that menu item on Windows.

Edit: I just realize this thread was started by a Mac User, so I understand the response.

You can download the beta for Windows directly from Lunacy by pressing Lunacy->About Lunacy->Download:

Hi @Alex_L

On Windows you have to select Help → About to access the download.

I’m now using version 9.6.0.5312, but the issue is still there. My Figma URL is still 2 characters longer than what the field allows.

Thanks for your time.

Got it, thanks! Could you please share the URL in the DMs?