Lunacy freezes after opening

Hi there! I was pleasantly surprised today to see that a Linux release is now available, so I won’t have to switch OS every time I want to work on my Sketch files. Thank you for the tremendous effort! That said, I tried it out, but unfortunately it doesn’t seem to work on my machine.

On Debian 12 testing, with a fresh .deb install of Lunacy, the application gets stuck directly after opening it. I see a tab that says “Tutorial”, and a loading indicator saying “Parsing…”, but even after several minutes it’s not done parsing. The window still resizes properly, and when I hover over a clickable button it lights up, but I cannot close the “Tutorial” tab, open a different file, or do anything else. After clicking a few times the application usually freezes up and becomes totally unresponsive.

I have tried removing the ~/.local/share/Icons8 directory, but that did not resolve my issue. Opening a .sketch file directly from Dolphin results in the same behaviour as above. I have not tried the Snap version because I don’t like Snap.


Same problem here.
I had a working Lunacy on my Linux machine.
All of a sudden from today, it has stopped working and started freezing and saying parsing...

1 Like

The same here (Ubuntu 18.04). It worked (I have installed just after the first release was out), but after the automatic update to 8.2 it freezes.


Uninstall and install worked for me. Though initial parsing takes time.

And if I try close during that parsing phase, it will freeze.
Tutorial seems too heavy for Lunacy to load.

Interesting. I started Lunacy, waited for five minutes, but nothing happened. I killed the process, uninstalled, reinstalled, started Lunacy, and after a bit over a minute the Tutorial was done loading. If I close Lunacy, delete ~/.local/share/Icons8 and then restart Lunacy, the Tutorial still loads correctly. I have no idea what’s going on here. But I doubt that it’s “too heavy to load” since I have a powerful PC.

But even then, it’s difficult to use the application because sometimes opening/closing files is super slow.

1 Like

Similar here. It took about 5 minutes for the “Analysiere…” phase. But I could load an image. The process seems to finish in the background. This is really annoying - especially on a laptop with limited battery.

OS: elementary OS 6.1
Installed: 8.1 rev 37 via snap

1 Like

Same on ubuntu 20.04, uninstall and install didn’t work for me


Hey there, folks!

We’ve aware of this issue and we’re working on fixing it at the moment. It’s quite tricky because it seems to be connected with the video card drivers.

For now we recommend closing all files before ending the session as a preventative measure.


same on ubuntu 21.10, tried both deb and snap, same result
thanks for the great software - even if I still have to try it :slight_smile:

–update –
Lunacy successfully started by adding permission to read/write on removable storage devices in ubuntu software

1 Like

solved for me in today release, thanks

1 Like

As of 8.2.0, and after removing ~/.local/share/Icons8/, the situation is mostly the same for me, unfortunately. Although it feels like Lunacy is a bit more responsive, I still find that closing files is a risky operation that sometimes takes more than 10 seconds to complete (Lunacy doesn’t freeze when I do that, but it does take a while to close a file, especially if the file is still loading). Closing Lunacy does cause the program to completely freeze up.

The same thing happens to me. I have to wait a while

Same issue with Debian :frowning: Very slow to start and then intermittently hangs/freezes. Absolutely amazing app on Windows.

We’re aware of this issue and currently working really hard to fix it as soon as possible.


Make sure to close your files before u exit the program … if u forgot to do that and the parsing problem occurs then go to ~/.local/share/Icon8/Lunacy/Settings then delete the “Tabs” file…