Lunacy Lost my work 😱

Lunacy version: Help → About (F1 or Fn+F1)

OS version:
Arch Linux

I just tried to modify the layer name and found that I couldn’t delete the layer. Based on my previous experience, I thought closing and reopening the file would solve the issue. However, when I closed the current file (without closing the Lunacy software) and opened it again, I realized that my recent modifications were gone :scream:. Additionally, when I opened the file, two copies were opened simultaneously. The file is stored in the cloud. What could be the reason for this? (59.6 KB)

Hey, please, try following those steps:

  1. On the Home Tab, right-click the document’s preview to open up the context menu;
  2. Click Show Version History;
  3. Click to open the previous versions of the document;
  4. Choose the required version and click FIle → Save in the menu bar to save it as a local .sketch file on your device;
  5. Import it back into Lunacy Cloud.

Let me know if it helps.

I have tried to view the version history and found that the latest version does not include my recent modifications. Fortunately, I did not lose many changes.

Also, I am unable to save the cloud document as a local document through File → Save, which is also a bug.


There was indeed a bug on 9.1 versions preventing saving cloud files as local ones in some cases. If you update to the latest version, it should work. Same goes for Prototyping.
If updating doesn’t help the prototyping issue, please check if all layers are inside the frame. Maybe the layer background is in the frame, but the actual content is not.

We can take a look at your file if you forward it to us (you can do upload it here or send it through PMs)

If you are using MS Store version, there was a bug with deleting layers, but updating to a beta fixed it as well.

I’m using the Linux version, and I can’t save cloud documents to local documents (It’s a another bug), so I can’t share files with you.

Please update to the beta version (Help → About → Check for Beta updates)

Ok, since I am using Arch Linux and there is no beta package in the AUR, I will try to write a script to install the beta version myself, and then I will reply you.

I have updated to the beta version now, and the Save As function is get work now. I will use it for a while to see if there are still problems, and I will give feedback here.

Based on the current duration of usage, I have not encountered this issue yet. It appears that it has been resolved in version 9.2. However, there are occasional instances where the shortcut keys become ineffective, and I am unsure of the underlying cause.

When you say that shortcut keys become ineffective, do you mean key combinations don’t work, or actions that these shortcuts do also become unavailable?

I frequently utilize the Ctrl + D function for duplication (it’s shortcuts?), and it seems that the simultaneous deletion function also ceases to work (I cannot recall with certainty as my project recently concluded, and I have scarcely utilized Lunacy lately).