MacOS input textbox don't autocomplete

Hi Team,

I don’t know if this issue is related to a recent MacOS Monterey update, but the autocomplete doesn’t work anymore. It’s a nightmare to work like this now

I tried using the previous version of Lunacy, the new beta version, but the result is the same.

My current Lunacy version:

I have tested it in W10 just to validate if the issue is with the MacOS update, but I am getting the same error. Going back version by version, the last version that was working correctly is the following:

Hey there,

Could you specify what exactly didn’t work? I’ve checked the autocomplete on my Monterey with the latest beta and everything seems to be working fine. BTW if you could record a screencast, it would be really helpful :raised_hands:

With 9.0.9 version:
Screen Recording 2023-06-28 at (751.3 KB)

With beta version:
Screen Recording 2023-06-28 at (2.8 MB)

Thanks for the screencasts! Just to clarify, is the issue that the font won’t change in the autocompleted text? Does this happen with all fonts? Sorry for keep asking questions, I just can’t duplicate this error, so it’s a bit confusing :slightly_smiling_face:

Hi @Alex_L

I am attaching another screencast, what I can see:

  • Even if I put the whole font name and I press Enter the font is not rendered in the text.
  • The first entered letter is not populating the font name. If I press ‘Select all text (Command+A)’ and then enter another letter, the result is the same, the textbox is not populating the font name with the first match.
  • But If I pressed another key like “Backspace” and then I enter the same key, in this case, the text box is auto filled with the first font match. But the problem is that, the trailing letters are not selected (blue selection) and in this case I cannot get the wanted font (with the leading letters).

Screen Recording 2023-06-29 at (1.6 MB)

Thank you for your detailed reply! We’re already working on fixing this issue, I hope that I’ll have some good news soon :raised_hands:

Hi @Alex_L

I tested this issue with the latest beta version, and I can confirm that the issue is no longer present. :+1:

Same issue here
Lunacy 9.1.1 on linux


This issue is fixed in the 9.2 beta, you can get it here: Release History

Hi @danielvalat,

You can also use the previous stable version: 9.0.9