Integer values only for X/Y/W/H?

Is it just me, or does Lunacy properties for x / y / width / height always try to round to integer values? So far i haven’t been able to find a setting that allows for more precision - is there a reason for this?

Hello, friend! Have you tried to use your arrow keys for more precision?

Just tried it and i can only move objects at a minimum of 1px increments.

I’m also trying to move individual vertices of the Line tool to subpixel precision, so having functionality to enable this would be great as well.

If you need to move an element less than 1 pixel - you need to use the input field of position or size on the right panel.

There is actually a known rounding bug in the current version. You’d better use the latest alpha release: Lunacy - Ready To Use <<< New Vector tool & UI kits! This bug has been fixed in the alpha.

Thank you for the heads-up - this seems to help.

As a side note, moving objects or line vertices via mouse can only be done in 1px increments, even when zoomed in considerably. Hopefully a future update can allow for higher precision via this method as well.